e-mail :

Registered in England and Wales company # 03449181.
 This website does not use cookies.

 © Copyright: Conwy Valley Systems Limited  2000-2017.

Conwy Valley Systems Limited,

Wells House, 12, Hawes Drive,

Deganwy, Conwy, LL31 9BW, United Kingdom.

VAT# GB 741 5190 48


A Geoscience Wales  founding member.

PETROG Home PETROG Home PETROG search

Additional Files

32 bit version (x86)

64 bit version (x64)

Devart v 3.5.7

Devart v 3.4.6

Additional Files


If, on PETROG start-up, you are shown one or more messages advising that you should update particular DLLs, then please download the appropriate zip files from the tables below, and extract the contents of these zips to the advised location.

Click here to see list of changes

Version  3.7.1.0

Camera

PETROG 3 executable only

32 bit version (x86)

PETROG 3 executable only

64 bit version (x64)

Leica

Lumenera

Nikon

No camera

PixeLINK

QImaging

Zeiss Axiocam

Zeiss ICc

PETROG 3 upgrade


Please download the relevant PETROG executable for your camera and system architecture (32 bit or 64 bit). Each release download has a file readme.txt to give you instructions on how to upgrade - if you are unsure of what to do and want to see that first then click here.


Note : from version 3.1.9.3 you will require a licence key to run PETROG or it will only run in demonstration mode. Licence keys will be sent out to users to all users with current maintenance and support contracts, but if you have not yet had one, or have forgotten your key then please contact us.


PETROG 3 supports the following Windows operating systems: Windows 10 and Windows 7. On Windows 10, it does not run under the Metropolitan interface, only the desktop. It should run under Windows 8/8.1 and Windows XP but we no longer support these platforms.


Please note that some camera manufacturers may not have Windows 10 compatible drivers for all their cameras.

 Important : This page is for upgrading from an earlier version of PETROG 3. For a new installation of PETROG 3 including upgrading from version 2 then go here